Visual Basic . "Лестница!" - VB

Формулировка задачи:

Ребята.Нужна ваша помощь в решении задачи. Есть лестница,состоящая из N ступенек. Нужно подняться с первой на последнюю ступеньку. Но некоторые ступеньки подпилены . Это всё задаётся пользователем. То есть используется массив ступенек. К примеру, N=6 , A=(1,0,1,1,0,1) 1-целая ступень,0-подпиленная Нужно найти ВСЕ возможные варианты. К примеру,для данного случая будет 3 варианта: 1) С первой на третью,потом на четвёртую,и на последнюю 2) С первой на третью,потом на последнюю 3) С первой на четвёртую,и на последнюю Есть код на 1С 8.1 =)))) если кто-то сможет интерпретировать его для VB ?)
--------------
Перем МассивСтупенек;
Процедура КнопкаВыполнитьНажатие(Кнопка)	МассивСтупенек = Новый Массив;	МассивСтупенек.Добавить(1);	МассивСтупенек.Добавить(0);	МассивСтупенек.Добавить(1);	МассивСтупенек.Добавить(1);	МассивСтупенек.Добавить(0);	МассивСтупенек.Добавить(1);	Сообщить(ПодсчетВариантов(0));
КонецПроцедуры
Функция ПодсчетВариантов(Ступенька)	Если Ступенька + 1 = МассивСтупенек.Количество() Тогда	Возврат 1;	ИначеЕсли Ступенька >= МассивСтупенек.Количество() Тогда	Возврат 0;	КонецЕсли;	ПравильныхХодов = 0;	Если Ступенька+2 >= МассивСтупенек.Количество() Тогда	Возврат ПравильныхХодов;	КонецЕсли;	Если МассивСтупенек[Ступенька+2] = 1 Тогда	ПравильныхХодов = ПравильныхХодов + ПодсчетВариантов(Ступенька+2);	КонецЕсли;	Если Ступенька+3 >= МассивСтупенек.Количество() Тогда	Возврат ПравильныхХодов;	КонецЕсли;	Если МассивСтупенек[Ступенька+3] = 1 Тогда	ПравильныхХодов = ПравильныхХодов + ПодсчетВариантов(Ступенька+3);	КонецЕсли;	Возврат ПравильныхХодов;
КонецФункции
--------------

Код к задаче: «Visual Basic . "Лестница!" - VB»

textual
'в текстовое поле ввести строку в формате "1,0,1,1,0,1" (без пробелов!)
a=split(textbox1.text, ",")
'дальше все так же как было

10   голосов, оценка 3.900 из 5


СОХРАНИТЬ ССЫЛКУ